<!DOCTYPE html>
<html lang="en" class="no-js">
<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<title>Nextcloud introduces collaborative rich text editor &#8211; Nextcloud</title>
<meta name="author" content="Nextcloud">
<meta itemprop="description" content="Nextcloud is the most deployed self-hosted file share and collaboration platform on the web. Access  &amp; collaborate across your devices. Your data remains under your control.">
<meta name="description" content="Nextcloud is the most deployed self-hosted file share and collaboration platform on the web. Access  &amp; collaborate across your devices. Your data remains under your control.">

<!-- Twitter Card data -->
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:site" content="@nextclouders">
<meta name="twitter:url" content="https://nextcloud.com/blog/nextcloud-introduces-collaborative-rich-text-editor">
<meta name="twitter:title" content="Nextcloud introduces collaborative rich text editor &#8211; Nextcloud">
<meta name="twitter:description" content="Nextcloud is the most deployed self-hosted file share and collaboration platform on the web. Access  &amp; collaborate across your devices. You stay in control over your data!">

<!-- Twitter summary card with large image must be at least 280x150px -->

<!-- Open Graph data -->
<meta property="og:title" content="Nextcloud introduces collaborative rich text editor &#8211; Nextcloud" />
<meta property="og:type" content="article" />
<meta property="og:url" content="https://nextcloud.com/blog/nextcloud-introduces-collaborative-rich-text-editor" />
<meta property="og:description" content="Nextcloud is the most deployed self-hosted file share and collaboration platform on the web. Access  &amp; collaborate across your devices. You decide what happens with your data, where it is and who can access it" />
<meta property="og:site_name" content="Nextcloud" />
<meta property="fb:admins" content="1032807203462807" />

<!-- set images for generic, twitter and Open Graph -->

<meta itemprop="image" content="https://nextcloud.com/media/Nextcloud-Text-screenshot.png">
<meta name="twitter:image" content="https://nextcloud.com/media/Nextcloud-Text-screenshot.png">
<meta name="twitter:image:src" content="https://nextcloud.com/media/Nextcloud-Text-screenshot.png">
<meta property="og:image" content="https://nextcloud.com/media/Nextcloud-Text-screenshot.png">

<meta name="theme-color" content="#0082c9">
<meta name="viewport" content="user-scalable=no, width=device-width, initial-scale=1, maximum-scale=1">
<link rel="shortcut icon" href="https://nextcloud.com/wp-content/themes/next/assets/img/common/favicon.png?x22777" />
<link rel="apple-touch-icon-precomposed" href="https://nextcloud.com/wp-content/themes/next/assets/img/common/favicon.png?x22777" />

<!--     <link rel="preconnect" href="https://fonts.gstatic.com/" crossorigin> -->
<!-- 	<link href="https://fonts.googleapis.com/css?family=Open+Sans:300,300i,400,400i,600,600i" rel="stylesheet"> -->
	<link rel="stylesheet" href="https://nextcloud.com/wp-content/cache/minify/0871c.css?x22777" media="all" />


	<link rel='dns-prefetch' href='//s.w.org' />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.0.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel="stylesheet" href="https://nextcloud.com/wp-content/cache/minify/a5ff7.css?x22777" media="all" />

<script type='text/javascript' src='/wp-includes/js/jquery/jquery.js?x22777'></script>
<script type='text/javascript' src='/wp-includes/js/jquery/jquery-migrate.min.js?x22777'></script>
<link rel='https://api.w.org/' href='https://nextcloud.com/wp-json/' />
<link rel="alternate" type="application/json+oembed" href="https://nextcloud.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnextcloud.com%2Fblog%2Fnextcloud-introduces-collaborative-rich-text-editor%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://nextcloud.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnextcloud.com%2Fblog%2Fnextcloud-introduces-collaborative-rich-text-editor%2F&#038;format=xml" />
	<link rel="canonical" href="https://nextcloud.com/blog/nextcloud-introduces-collaborative-rich-text-editor/">
<link rel="icon" href="https://nextcloud.com/media/screenshot-150x150.png?x22777" sizes="32x32" />
<link rel="icon" href="https://nextcloud.com/media/screenshot.png?x22777" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://nextcloud.com/media/screenshot.png?x22777" />
<meta name="msapplication-TileImage" content="https://nextcloud.com/media/screenshot.png" />
	<script type="text/javascript">
		var templateUrl = 'https://nextcloud.com/wp-content/themes/next';
	</script>

	<script data-main="https://nextcloud.com/wp-content/themes/next/assets/js/require.config.js"
	src="https://nextcloud.com/wp-content/themes/next/node_modules/requirejs/require.min.js?x22777">
	</script>

	<script>
	require(["require.config"], function() {
		require(["modules/header", "main", "modernizr", "modules/cookieconsent"])
	});
	</script>

</head>
<body class="post-template-default single single-post postid-6138 single-format-standard nextcloud-introduces-collaborative-rich-text-editor not-front"><!-- <link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css"> -->

<nav class="nav" id="nav">
<!-- To finish -->
	<div class="mobile-bg-container">
		<div class="mobile-bg"></div>
	</div>

	<div class="container">
		<div class="nav__bg-wrapper">
			<div class="nav__bg"></div>
		</div>
		<div class="brand">
			<a href="https://nextcloud.com/homepage">
				<div class="logo"></div></a>
		</div>
		<button type="button" class="navbar-toggle collapsed" id="toggle">
			<div class="menu-animation" data-animation-path="img/menu/black/" data-anim-loop="false" data-name="menu-black" id="menu-black"></div>
		</button>
			<div class="nav__sections-wrapper">
			<ul class="nav__sections">

				<li class="nav__section"><a class="nav__label">Products</a>
					<ul class="nav__links ">
						<li class="nav__item">
                            <a href="https://nextcloud.com/files">
                            <div class="nav__logo">
                                <svg xmlns="http://www.w3.org/2000/svg" height="16" viewBox="0 0 16 16" width="16" version="1.1"><path fill="#0082c9" d="m1.5 2c-0.25 0-0.5 0.25-0.5 0.5v11c0 0.26 0.24 0.5 0.5 0.5h13c0.26 0 0.5-0.241 0.5-0.5v-9c0-0.25-0.25-0.5-0.5-0.5h-6.5l-2-2h-4.5zm8.75 3.5a1.25 1.25 0 0 1 1.25 1.25 1.25 1.25 0 0 1 -1.25 1.25 1.25 1.25 0 0 1 -0.8008 -0.291l-2.4512 1.2265a1.25 1.25 0 0 1 0.002 0.0645 1.25 1.25 0 0 1 -0.0039 0.0645l2.4531 1.2265a1.25 1.25 0 0 1 0.8008 -0.291 1.25 1.25 0 0 1 1.25 1.25 1.25 1.25 0 0 1 -1.25 1.25 1.25 1.25 0 0 1 -1.25 -1.25 1.25 1.25 0 0 1 0.0039 -0.064l-2.4531-1.227a1.25 1.25 0 0 1 -0.8008 0.291 1.25 1.25 0 0 1 -1.25 -1.25 1.25 1.25 0 0 1 1.25 -1.25 1.25 1.25 0 0 1 0.8008 0.291l2.4512-1.2265a1.25 1.25 0 0 1 -0.002 -0.0645 1.25 1.25 0 0 1 1.25 -1.25z"/></svg>
                            </div>
                            <div class="nav__text"><strong>Nextcloud Files</strong><br><small>File Sync and Share</small></div>
                        </a>
                        </li>
						<li class="nav__item">
							<a href="https://nextcloud.com/talk">
                                <div class="nav__logo">
                                    <svg xmlns="http://www.w3.org/2000/svg" height="16" width="16" version="1.1" viewBox="0 0 16 16"><path fill="#0082c9" d="m7.9992 0.999a6.9993 6.9994 0 0 0 -6.9992 6.9996 6.9993 6.9994 0 0 0 6.9992 6.9994 6.9993 6.9994 0 0 0 3.6308 -1.024c0.86024 0.34184 2.7871 1.356 3.2457 0.91794 0.47922-0.45765-0.56261-2.6116-0.81238-3.412a6.9993 6.9994 0 0 0 0.935 -3.4814 6.9993 6.9994 0 0 0 -6.9991 -6.9993zm0.0008 2.6611a4.34 4.3401 0 0 1 4.34 4.3401 4.34 4.3401 0 0 1 -4.34 4.3398 4.34 4.3401 0 0 1 -4.34 -4.3398 4.34 4.3401 0 0 1 4.34 -4.3401z" stroke-width="0.14"/></svg>
                                </div>
                                <div class="nav__text">
                                    <strong>Nextcloud Talk</strong><br><small>Calls, chat and web meetings</small>                                </div>
                            </a>
                        </li>
						<li class="nav__item">
                            <a href="https://nextcloud.com/groupware">
                                <div class="nav__logo">
                                    <svg xmlns="http://www.w3.org/2000/svg" viewbox="0 0 16 16" height="16" width="16" version="1.1"><path fill="#0082c9" d="m9 1c-1.746 0-3 1.43-3 2.8 0 1.4 0.1 2.4 0.8 3.5 0.224 0.29 0.485 0.35 0.7 0.6 0.135 0.5 0.24 1 0.1 1.5-0.436 0.153-0.85 0.332-1.27 0.5-0.51-0.273-1.1-0.5-1.61-0.7-0.07-0.28-0.02-0.487 0.05-0.75 0.12-0.125 0.23-0.18 0.36-0.3 0.37-0.45 0.39-1.21 0.39-1.75 0-0.8-0.72-1.4-1.5-1.4-0.87 0-1.5 0.72-1.5 1.4h-0.02c0 0.7 0.05 1.2 0.4 1.75 0.1 0.15 0.242 0.175 0.35 0.3 0.0674 0.25 0.121 0.5 0.05 0.75-0.64 0.223-1.244 0.5-1.8 0.8-0.42 0.3-0.233 0.182-0.5 1.15-0.124 0.5 1.3 0.73 2.32 0.81-0.05 0.275-0.12 0.64-0.32 1.34-0.32 1.25 4.353 1.7 6 1.7 2.43 0 6.313-0.456 5.98-1.7-0.52-1.94-0.208-1.71-0.98-2.3-1.09-0.654-2.452-1.167-3.6-1.6-0.15-0.557-0.04-0.97 0.1-1.5 0.235-0.25 0.5-0.36 0.72-0.6 0.69-0.884 0.78-2.424 0.78-3.5 0-1.586-1.43-2.8-3-2.8z"/></svg>
                                </div>
                                <div class="nav__text">
                                    <strong>Nextcloud Groupware</strong><br><small>Calendar, Contacts & Mail</small>                                </div>
                            </a>
                        </li>
						<li class="nav__item">
                            <a href="https://nextcloud.com/athome">
                                <div class="nav__logo">
                                    <svg xmlns="http://www.w3.org/2000/svg" height="16" width="16" version="1.1" viewBox="0 0 16 16"><path fill="#0082c9" d="M8 1.03L0 9h3v6h10V9h3l-3-3.03V2h-3v1.08L8 1.03z" fill-rule="evenodd"/></svg>
                                </div>
                                <div class="nav__text">
                                    <strong>Nextcloud at home</strong><br><small>For families, students & you</small>                                </div>
                            </a>
                        </li>
                        <li class="nav__item">
                            <a href="https://nextcloud.com/industries">
                                <div class="nav__logo">
                                    <svg xmlns="http://www.w3.org/2000/svg" height="300" width="300" fill="#0082c9" version="1.0" viewBox="0 0 16 16"><path style="text-indent:0;text-transform:none" d="M8.009.275c-.471 0-.961.542-.95 1v9.413c-.007.528.422 1 .95 1s.957-.472.95-1V1.275a.967.967 0 0 0-.95-1z" color="#000"/><path style="text-indent:0;text-transform:none" d="M0 5.537c0 .471.542.961 1 .95l14.007-.042c.528.007 1-.422 1-.95 0-.529-.472-.958-1-.95L1 4.587a.967.967 0 0 0-1 .95z" color="#000"/><path style="text-indent:0;text-transform:none" d="M15.05 4.587c-.472 0-.961.542-.95 1v5.146c-.008.529.421 1 .95 1 .528 0 .957-.471.95-1V5.587a.967.967 0 0 0-.95-1zM.95 4.587c-.471 0-.96.542-.95 1v5.146c-.007.529.422 1 .95 1 .529 0 .958-.471.95-1V5.587a.967.967 0 0 0-.95-1zM.95 12.8c-.471 0-.96.542-.95 1v-.007c-.007.528.422 1 .95 1 .529 0 .958-.472.95-1v.007a.967.967 0 0 0-.95-1zM8.009 12.755c-.471 0-.961.542-.95 1v-.008c-.008.529.422 1 .95 1s.957-.471.95-1v.008a.967.967 0 0 0-.95-1zM15.05 12.8c-.472 0-.961.542-.95 1v-.007c-.008.528.421 1 .95 1 .528 0 .957-.472.95-1v.007a.967.967 0 0 0-.95-1z" color="#000"/></svg>                                </div>
                                <div class="nav__text">
                                    <strong>Industry solutions</strong><br><small>Optimized for your enterprise</small>                                </div>
                            </a>
                        </li>
                        <hr>
                        <li class="nav__item"><a href="https://nextcloud.com/outlook">Outlook integration</a></li>
                        <li class="nav__item"><a href="https://nextcloud.com/onlyoffice">ONLYOFFICE online office</a></li>
                        <li class="nav__item"><a href="https://nextcloud.com/collaboraonline">Collabora online office</a></li>
                        <li class="nav__item"><a href="https://nextcloud.com/globalscale">Global Scale</a></li>
                    </ul>
				</li>

				<li class="nav__section"><a class="nav__label">Support</a>
					<ul class="nav__links">
                        <li class="nav__item"><a href="https://portal.nextcloud.com">Nextcloud Support</a></li>
                        <li class="nav__item"><a href="https://help.nextcloud.com">Community support</a></li>
						<li class="nav__item"><a href="https://nextcloud.com/pricing#faq">FAQ</a></li>
						<li class="nav__item"><a href="https://nextcloud.com/pricing">Pricing</a></li>
						<li class="nav__item"><a href="https://nextcloud.com/support">Documentation</a></li>
						<li class="nav__item"><a href="https://nextcloud.com/whitepapers">White papers</a></li>
						<li class="nav__item"><a href="https://nextcloud.com/migration">Migration</a></li>
						<li class="nav__item"><a href="https://apps.nextcloud.com">App Store</a></li>
					</ul>
				</li>

				<li class="nav__section"><a class="nav__label">Community</a>
					<ul class="nav__links">
						<li class="nav__item"><a href="https://nextcloud.com/contribute">How to contribute</a></li>
						<li class="nav__item"><a href="https://github.com/nextcloud">Code on GitHub</a></li>
<!-- 						<li class="nav__item"><a href="https://nextcloud.com/news">Contributor blogs</a></li> -->
						<li class="nav__item"><a href="https://github.com/nextcloud/server/issues/new/choose">Report a bug</a></li>
						<li class="nav__item"><a href="https://docs.nextcloud.com/server/16/developer_manual/">Developer Docs</a></li>
						<li class="nav__item"><a href="https://nextcloud.com/code-of-conduct">Code of Conduct</a></li>
<!--						<li class="nav__item"><a href="https://nextcloud.com/contributors">Community members</a></li>-->
						<li class="nav__item"><a href="https://nextcloud.com/security">Security information</a></li>
					</ul>
				</li>

				<li class="nav__section"><a class="nav__label">About</a>
					<ul class="nav__links">
						<li class="nav__item"><a href="https://nextcloud.com/about">About us</a></li>
						<li class="nav__item"><a href="https://nextcloud.com/blog">Blog</a></li>
						<li class="nav__item"><a href="https://nextcloud.com/secure">Security</a></li>
						<li class="nav__item"><a href="https://nextcloud.com/team">Team</a></li>
						<li class="nav__item"><a href="https://nextcloud.com/partners">Partners</a></li>
						<li class="nav__item"><a href="https://nextcloud.com/events">Events</a></li>
						<li class="nav__item"><a href="https://nextcloud.com/jobs">Jobs</a></li>
						<li class="nav__item"><a href="https://nextcloud.com/compare">Comparison with others</a></li>
						<li class="nav__item"><a href="https://nextcloud.com/search">Search our site</a></li>
					</ul>
				</li>
            </ul>
            <ul class="right-buttons">
                <li class="nav__section"><a class="nav__label">Get Nextcloud</a>
                    <ul class="nav__links ">
                        <li class="nav__item">
                            <a href="https://nextcloud.com/install/#instructions-server">
                                <div class="nav__logo">
                                    <svg xmlns="http://www.w3.org/2000/svg" height="16" viewBox="0 0 16 16" width="16" version="1.1"><path d="m6.94 0.5c-0.24 0-0.44 0.2-0.44 0.44v1.26c-0.5 0.14-1.05 0.35-1.53 0.65l-0.91-0.91c-0.16-0.18-0.46-0.19-0.62 0l-1.5 1.5c-0.18 0.17-0.18 0.46 0 0.62l0.91 0.91c-0.284 0.48-0.5 1-0.65 1.53h-1.26c-0.24 0-0.44 0.2-0.44 0.44v2.12c0 0.25 0.19 0.44 0.44 0.44h1.26c0.14 0.54 0.36 1.05 0.65 1.53l-0.91 0.91c-0.18 0.17-0.18 0.45 0 0.62l1.5 1.5c0.18 0.18 0.46 0.18 0.62 0l0.91-0.91c0.48 0.285 1 0.5 1.53 0.65v1.26c0 0.25 0.2 0.44 0.44 0.44h2.12c0.24 0 0.45-0.2 0.44-0.44v-1.26c0.54-0.14 1.05-0.36 1.53-0.65l0.91 0.91c0.17 0.18 0.45 0.18 0.62 0l1.5-1.5c0.18-0.17 0.18-0.45 0-0.62l-0.91-0.91c0.29-0.48 0.5-1 0.65-1.53h1.26c0.24 0 0.45-0.2 0.44-0.44v-2.12c0-0.24-0.2-0.44-0.44-0.44h-1.26c-0.14-0.54-0.36-1.05-0.65-1.53l0.91-0.91c0.18-0.17 0.18-0.45 0-0.62l-1.5-1.5c-0.17-0.18-0.45-0.18-0.62 0l-0.91 0.91c-0.48-0.29-1-0.5-1.53-0.65v-1.26c0-0.24-0.2-0.44-0.44-0.44h-2.12zm1.06 4a3.5 3.5 0 0 1 3.5 3.5 3.5 3.5 0 0 1 -3.5 3.5 3.5 3.5 0 0 1 -3.5 -3.5 3.5 3.5 0 0 1 3.5 -3.5z" fill="#0082c9"/></svg>
                                </div>
                                <div class="nav__text">
                                    <strong>Server packages</strong><br><small>For self-hosting on your server</small>                                </div>
                            </a>
                        </li>
                        <li class="nav__item">
                            <a href="https://nextcloud.com/install/#install-clients">
                                <div class="nav__logo">
                                    <svg xmlns="http://www.w3.org/2000/svg" height="16" width="16" version="1.1" viewBox="0 0 16 16"><path d="m2 2c-0.554 0-1 0.446-1 1v8c0 0.554 0.446 1 1 1h5v1h-2v2h6v-2h-2v-1h5c0.554 0 1-0.446 1-1v-8c0-0.554-0.446-1-1-1zm1 2h10v6h-10z" fill="#0082c9"/></svg>
                                </div>
                                <div class="nav__text">
                                    <strong>Desktop & mobile apps</strong><br><small>Windows, macOS, Linux, Android, iOS, …</small>                                </div>
                            </a>
                        </li>
                        <li class="nav__item">
                            <a href="https://nextcloud.com/signup">
                                <div class="nav__logo">
                                    <svg height='300px' width='300px'  fill="#0082c9" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#" xmlns="http://www.w3.org/2000/svg" xmlns:cc="http://creativecommons.org/ns#" xmlns:dc="http://purl.org/dc/elements/1.1/" version="1.1" x="0px" y="0px" viewBox="0 0 16 16"><g transform="translate(0 -1036.4)"><path style="" d="m12.594 1.3438c-0.532-0.0313-1.094 0.1562-1.594 0.6562l3 3c1.5-1.5 0.188-3.5625-1.406-3.6562zm-2.594 1.6562l-7 7-2 5 5-2 7-7-3-3zm-6.5 7.5l2 2-2.5 1.5-1-1 1.5-2.5z" transform="translate(0 1036.4)"></path></g></svg>
                                </div>
                                <div class="nav__text">
                                    <strong>Sign up now</strong><br><small>Get a free account at a provider</small>                                </div>
                            </a>
                        </li>
                        <li class="nav__item">
                            <a href="https://nextcloud.com/devices">
                                <div class="nav__logo">
                                    <svg height='300px' width='300px'  fill="#0082c9" xmlns="http://www.w3.org/2000/svg" version="1.0" x="0px" y="0px" viewBox="0 0 16 16"><path style="block-progression:tb;color:#000000;text-transform:none;text-indent:0;" d="m8.0001 0c-0.4714 0-0.96103 0.5419-0.95 1v6c-0.00747 0.52831 0.42163 1 0.95 1s0.95747-0.47169 0.95-1v-6c0.014622-0.6051-0.4786-1-0.95-1zm-3.3438 2.5c-0.087186 0.019294-0.17163 0.050959-0.25 0.09375-2.9995 1.5715-3.9184 4.7979-3.125 7.4688 0.7934 2.67 3.2799 4.937 6.6875 4.937 3.3592 0 5.8772-2.149 6.7192-4.781 0.841-2.6321-0.058-5.8234-3.125-7.594-0.434-0.2536-1.059-0.0899-1.313 0.3437-0.2536 0.4336-0.09 1.0589 0.344 1.3125 2.3908 1.3798 2.8825 3.4944 2.2812 5.375-0.6012 1.8806-2.344 3.4375-4.9062 3.4375-2.5759 0-4.2976-1.6502-4.875-3.5938-0.5776-1.9435-0.047-4.048 2.1873-5.2187 0.3787-0.2063 0.5791-0.6925 0.4558-1.1057-0.1232-0.4133-0.5572-0.7103-0.987-0.6755-0.0313-0.0015-0.0626-0.0015-0.0938 0z"></path></svg>
                                </div>
                                <div class="nav__text">
                                    <strong>Devices</strong><br><small>Buy hardware with Nextcloud</small>                                </div>
                            </a>
                        </li>
                        <li class="nav__item">
                            <a href="https://nextcloud.com/enterprise">
                                <div class="nav__logo">
                                    <svg xmlns="http://www.w3.org/2000/svg" version="1.1" viewbox="0 0 16 16" width="16" height="16"><path d="m8 0a3 3 0 0 0 -2.828 2 3 3 0 0 0 -0.172 -0 3 3 0 0 0 -3 3 3 3 0 0 0 0 0.172 3 3 0 0 0 -2 2.828 3 3 0 0 0 2 2.828 3 3 0 0 0 -0 0.172 3 3 0 0 0 3 3 3 3 0 0 0 0.172 -0 3 3 0 0 0 2.828 2 3 3 0 0 0 2.828 -2.01 3 3 0 0 0 0.172 0.01 3 3 0 0 0 3 -3 3 3 0 0 0 -0 -0.172 3 3 0 0 0 2 -2.828 3 3 0 0 0 -2.01 -2.828 3 3 0 0 0 0.01 -0.172 3 3 0 0 0 -3 -3 3 3 0 0 0 -0.172 0 3 3 0 0 0 -2.828 -2zm2.934 4.5625 1.433 1.4336-5.7772 5.7789-2.9511-2.9508 1.414-1.414 1.5371 1.5351 4.3442-4.3828z" fill="#0082c9"/></svg>
                                </div>
                                <div class="nav__text">
                                    <strong>Enterprise solution</strong><br><small>For mission-critical use</small>                                </div>
                            </a>
                        </li>
                    </ul>
                </li>
                <li class="ghost-btn">
                    <a href="https://demo.nextcloud.com/" class="nav__label">
                        Demo                    </a>
                </li>
                <li class="ghost-btn">
                    <a href="https://nextcloud.com/gdpr" class="nav__label">
                        GDPR                    </a>
                </li>
                <li class="ghost-btn no-underline">
                    <a href="https://nextcloud.com/contact" class="nav__label top-navbar-svg"><?xml version="1.0" encoding="UTF-8" standalone="no"?>
<svg
   xmlns:dc="http://purl.org/dc/elements/1.1/"
   xmlns:cc="http://creativecommons.org/ns#"
   xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
   xmlns:svg="http://www.w3.org/2000/svg"
   xmlns="http://www.w3.org/2000/svg"
   xmlns:sodipodi="http://sodipodi.sourceforge.net/DTD/sodipodi-0.dtd"
   xmlns:inkscape="http://www.inkscape.org/namespaces/inkscape"
   height="20"
   width="20"
   version="1.0"
   viewBox="0 0 20 20"
   id="svg4"
   sodipodi:docname="mail.svg"
   inkscape:version="0.92.3 (2405546, 2018-03-11)">
  <metadata
     id="metadata10">
    <rdf:RDF>
      <cc:Work
         rdf:about="">
        <dc:format>image/svg+xml</dc:format>
        <dc:type
           rdf:resource="http://purl.org/dc/dcmitype/StillImage" />
        <dc:title />
      </cc:Work>
    </rdf:RDF>
  </metadata>
  <defs
     id="defs8" />
  <sodipodi:namedview
     pagecolor="#ffffff"
     bordercolor="#666666"
     borderopacity="1"
     objecttolerance="10"
     gridtolerance="10"
     guidetolerance="10"
     inkscape:pageopacity="0"
     inkscape:pageshadow="2"
     inkscape:window-width="1920"
     inkscape:window-height="1007"
     id="namedview6"
     showgrid="false"
     inkscape:snap-bbox="true"
     inkscape:bbox-paths="true"
     inkscape:bbox-nodes="true"
     inkscape:snap-bbox-edge-midpoints="true"
     inkscape:snap-page="true"
     inkscape:zoom="7.375"
     inkscape:cx="-6.3728814"
     inkscape:cy="16"
     inkscape:window-x="0"
     inkscape:window-y="0"
     inkscape:window-maximized="1"
     inkscape:current-layer="svg4" />
  <path
     d="M 1.111132,3.749836 C 0.49555934,3.749836 0,4.2457766 0,4.861343 v 10.278814 c 0,0.615629 0.49555934,1.110007 1.111132,1.110007 H 18.888743 C 19.504372,16.250164 20,15.755786 20,15.140157 V 4.861343 C 20,4.2457766 19.504372,3.749836 18.888743,3.749836 Z m 0.9375058,1.285133 7.6044224,7.604423 h 0.6597548 l 7.638797,-7.604423 0.76388,0.7638798 -4.548654,4.6180912 3.437521,3.50696 -0.763879,0.763879 -3.506959,-3.506959 -2.534766,2.569454 H 9.2014949 L 6.6671041,11.181507 3.1599573,14.722779 2.3960149,13.924025 5.8682866,10.417128 1.2849456,5.7992238 Z"
     id="path2"
     inkscape:connector-curvature="0"
     style="fill:#ffffff;stroke-width:0.62500387;fill-opacity:1" />
</svg>
</a>
                </li>
                <li class="nav__section"><a class="nav__label top-navbar-svg lang-icon"><?xml version="1.0" encoding="UTF-8"?>
<svg width="20" height="20" fill="#000000" version="1.1" viewBox="0 0 6.6666669 6.6666669" xmlns="http://www.w3.org/2000/svg" xmlns:cc="http://creativecommons.org/ns#" xmlns:dc="http://purl.org/dc/elements/1.1/" xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#">
    <g transform="matrix(.083333 0 0 .083333 -.83333 -1)" fill="#fff" data-name="Layer 9">
        <polygon points="27.08 43 32.93 43 30 33.49"/>
        <path d="m38 14h-20a8 8 0 0 0 -8 8v68l24-24h18zm-3.84 33h-8.31l-1.85 6h-4l8-26h4l8 26h-4z"/>
        <path d="m82 14h-40l14 52h26a8 8 0 0 0 8 -8v-36a8 8 0 0 0 -8 -8zm-14 13h4v4h-4zm12 26a26.81 26.81 0 0 1 -10.64 -2.1 21.79 21.79 0 0 1 -9.36 2.1v-4a17.9 17.9 0 0 0 5 -0.7c-3.09-2.46-5-5.69-5-9.3h4c0 2.88 2.08 5.51 5.32 7.36a13.54 13.54 0 0 0 6.68 -11.36h-16v-4h20v4a17.15 17.15 0 0 1 -6.37 13.13 23.34 23.34 0 0 0 6.37 0.87z"/>
    </g>
</svg>
</a>
                    <ul class="nav__links">
                        <li class="nav__item nav__item__language">
                            <a href="https://nextcloud.com/de/">
															<span class="flag-icon flag-icon-de"></span>
															Deutsch
														</a>
                        </li>
                        <li class="nav__item nav__item__language">
                            <a href="https://nextcloud.com/">
															<span class="flag-icon flag-icon-us"></span>
															English
														</a>
                        </li>
                        <li class="nav__item nav__item__language">
                            <a href="https://nextcloud.com/fr_FR/">
															<span class="flag-icon flag-icon-fr"></span>
															Français
														</a>
                        </li>
                    </ul>
                </li>
            </ul>
			</div>
		</div>
	</div>
</nav>

<script>
    var selector = document.getElementById('nav');
    selector.style.opacity = 0;
</script>

<style>
.no-js body nav {
  opacity: 1; }
</style>
<!-- A single blog post -->
  <article class="post-6138 post type-post status-publish format-standard has-post-thumbnail hentry category-news">
  <head>
	<link rel="stylesheet" href="https://nextcloud.com/wp-content/cache/minify/fd9c2.css?x22777" media="all" />

	
    <script src="https://nextcloud.com/wp-content/themes/next/assets/js/dsgvo-video-embed.min.js?x22777"></script>
<script>
	require(["require.config"], function() {
		require(["modules/youtubePlayer", "modules/codeHighlights"])
	});
</script>
</head>
<section class="section--blog-header">
<div class="background blog-background">
	<div class="container">
		<div class="row">
			<div class="topheader">
<!-- 				<h1>The Nextcloud blog</h1> -->
			</div>
		</div>
	</div>
</div>
</section>
<section class="section--content">
<div class="container">
    <div class="row">
        <div class="content col-md-10 col-md-offset-1">
            <h1>Nextcloud introduces collaborative rich text editor</h1>
            <h2 class="blog-metadata"><time class="published" datetime="2019-06-27T10:00:53+00:00">June 27, 2019</time>
                    <a target="_blank" href="https://twitter.com/intent/tweet/?url=https%3A%2F%2Fnextcloud.com%2Fblog%2Fnextcloud-introduces-collaborative-rich-text-editor%2F&via=nextclouders&hashtags=nextcloud">
                        <img class="blog-social" src="https://nextcloud.com/wp-content/themes/next/assets/img/social/twitterround.png?x22777"></img>
                    </a>
                    <a target="_blank" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fnextcloud.com%2Fblog%2Fnextcloud-introduces-collaborative-rich-text-editor%2F">
                        <img class="blog-social" src="https://nextcloud.com/wp-content/themes/next/assets/img/social/facebook.png?x22777"></img>
                    </a>
                    <a target="_blank" href="https://plus.google.com/share?url=https%3A%2F%2Fnextcloud.com%2Fblog%2Fnextcloud-introduces-collaborative-rich-text-editor%2F">
                        <img class="blog-social" src="https://nextcloud.com/wp-content/themes/next/assets/img/social/googleplus.png?x22777"></img>
                    </a>
                <br>
                <small>posted in <a href="https://nextcloud.com/blog/category/news/" rel="category tag">news</a> by <a href="https://nextcloud.com/blog/" title="Posts by Jos Poortvliet" rel="author">Jos Poortvliet</a></small>
                </h2>
        <div class="entry-content">
            <p>You need to take meeting notes with your colleagues. You quickly want to jot down some thoughts. You draft a new proposal during a team call. Just some reasons why you might need a lightweight, distraction-free text editor that lets you edit text with multiple users. Of course, heavy-weight solutions with full MS Office support exist, but if bold, headers, bullet points and images cover most of your needs, Nextcloud has you covered!</p>
<p><img src="https://nextcloud.com/media/Nextcloud-Text-screenshot.png?x22777" alt="Nextcloud Text screenshot.png" class="banner" /></p>
<p><strong>We&#8217;re happy to announce Nextcloud Text, an easy to use, collaborative rich-text editor using Markdown under the hood.</strong> The first release is available immediately for Nextcloud 16 users, and it will be our standard text editor in Nextcloud 17. Try it out now!</p>
<div class="text-center" style="margin-top: 50px; margin-bottom: 50px;"><a class="button button--large button--blue button--arrow" href="https://apps.nextcloud.com/apps/text">Download now!</a></div>
<h2 id="focusedcollaboration">Focused collaboration</h2>
<p>In a world where distractions are everywhere, clean, focused text editors are becoming more popular. If you need to structure your thoughts, brainstorm an idea or take notes, the million-and-one features of a word processor just hold you back.</p>
<p>Nextcloud Text lets the content take center stage.</p>
<p>That is not to say Nextcloud Text isn&#8217;t a capable editor. Besides the basic markup like Bold, italics &amp; headers, you can insert images and we plan to support tables, mentioning other users and more. Another <em>major</em> plus is that you can work with any number of people at the same time, sharing your ideas and thoughts in real time.</p>
<p>There is more. You probably missed it in the long <a href="https://nextcloud.com/blog/nextcloud-16-introduces-machine-learning-based-security-and-usability-features-acl-permissions-and-cross-app-projects/">list of features for Nextcloud 16,</a> but we introduced a new file viewer in the release last April.</p>
<blockquote>
<p>A new document viewer is introduced, replacing the video player and Gallery app for quick previewing of media. The app can be extended to other file formats and is available for app developers for easy integration in their applications.</p>
</blockquote>
<p>This promised integration is used by Text, giving it access to the same sidebar as you have when editing documents in Collabora Online that we <a href="https://nextcloud.com/blog/mobile-app-integration-for-online-office-talk-in-the-file-sidebar-and-much-improved-sharing/">introduced last December</a>. So, you can easily access sharing, comments and older versions. And when you share a note with a link, you can have a call or chat in the sidebar with the recipient(s)!</p>
<h3 id="comingtogether">Coming together</h3>
<p>To illustrate where Nextcloud Text takes you, let&#8217;s describe a possible meeting you&#8217;ll have one day.</p>
<p>You have shared the meeting notes template in advance with all members. It has a basic structure, making sure nothing gets missed.</p>
<p><img src="https://nextcloud.com/media/meeting-note-template-in-Text.png?x22777" alt="meeting note template in Text.png"  /><br />
During the meeting, one person is dedicated note takers, while the others should check and make sure the notes are correct. As two members couldn&#8217;t make it, a call is started (conveniently in the side bar) while chat is used to coordinate.</p>
<p><img src="https://nextcloud.com/media/Nextcloud-Text-in-a-call.png?x22777" alt="Nextcloud Text in a call.png" class="banner"/></p>
<p>Of course, if needed, the participants can roll back the notes to an earlier version from the Versions view in the sidebar, and when people are mentioned in the comments, they will receive a notification on their phone. A great way to ping the people who are late to the call!</p>
<p><img src="https://nextcloud.com/media/Nextcloud-Text-Sidebar.gif?x22777" alt="Nextcloud Text Sidebar.gif" class="banner" /><br />
After the meeting, and going forward, everybody gets the notes synced to their mobile and desktop devices for easy local editing and a link can be send to others, showing the document the way it was written.</p>
<p>Nextcloud Text and Talk don&#8217;t make your meetings magically successful &#8211; but they will make them more efficient!</p>
<h3 id="markdown">Markdown</h3>
<p>Markdown is a minimalist writing system, designed to let you write your thoughts down and structure them without all the overhead that comes with styling. It uses plain text with some logical, some say obvious, modifiers to make lists, emphasize things and show some structure. For example, a markdown list looks like this:</p>
<pre><code>* item 1
* item 2
* item 3
</code></pre>
<p>You are forgiven for thinking &#8220;<em>well, that&#8217;s how I always make a list</em>. Indeed, that is how intuitive Markdown is. Emphasis is also created with *, for example <code>*this*</code> and <code>**this**</code>. One star is commonly shown as <em>italics</em>, two as <strong>bold</strong>. You can learn more about Markdown <a href="https://commonmark.org/">on this website</a> &#8211; which claims to teach you markdown in 60 seconds. After the two paragraph introduction above, we think it will only take you 30&#8230;</p>
<p>Our editor largely &#8216;hides&#8217; the markdown from you: type a * and a space on a new line, and it becomes a bullet. Surround a word with two <code>**</code> and it will become bold. But you can also select the word and hit <code>ctrl-b</code> or use the <code>B</code>button in the tool bar &#8211; do what works best for you!</p>
<p>The files are stored as <code>.md</code> files, plain text files with the stars &amp; hashes sprinkled in, easily readable in any text editor &#8211; but, of course, looking best in one that also understands Markdown.</p>
<p>As always, Nextcloud stands on the shoulders of Open Source giants, and Nextcloud Text is based on <a href="https://prosemirror.net/">ProseMirror</a> and <a href="https://tiptap.scrumpy.io/">tiptap</a>! Kudos to their developers for their amazing work.</p>
<h2 id="inaction">In action</h2>
<p>Today, version 1.0 of Nextcloud Text is available in <a href="https://apps.nextcloud.com">our app store</a> and you can download it for Nextcloud 16. We have already been using it for a while internally in Nextcloud and we&#8217;re very enthusiastic about it, we hope you are, too!</p>
<p>Over the next weeks will continue to improve the app, both in terms of features, design and of course stability. When Nextcloud 17 is released, the plan is that Nextcloud Text will replace the current text editor, bringing collaborative rich-text editing to Nextcloud out-of-the-box.</p>
<p>We are also discussing what to do on mobile. While a web view is possible and would allow collaborative editing, the Android Notes app works very nicely with Markdown and might be an alternative solution.</p>
<p>Last but absolutely not least, <strong>you can get involved!</strong> Nextcloud Text can be <a href="https://github.com/nextcloud/text">found on Github</a> and we welcome your feedback, issue reports, and contributions! 😊</p>
<p><a href="https://github.com/nextcloud/text">Get started!</a></p>
        </div>
        </div>
    </div>
</div>
</section>
<section class="section--footer">
<div class="container">
    <div class="row">
    <div class="col-md-10 col-md-offset-1">
<!--     <footer> -->
<!--        -->
        
	<nav class="navigation post-navigation" role="navigation">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://nextcloud.com/blog/introducing-hkn-the-biggest-multiregion-german-openstack-cloud/" rel="prev"><span class="meta-nav" aria-hidden="true">Previous post:</span> <span class="post-title">Introducing HKN, the biggest multiregion German Openstack Cloud!</span></a></div></div>
	</nav><!--     </footer> -->
    		<div id="comments" class="comments-area discourse-comments-area">
            <div class="comments-title-wrap">
                <h2 class="comments-title discourse-comments-title">Notable Replies</h2>
            </div>
			<ol class="comment-list">		<li class="comment even depth-1">
			<article class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt="" src="https://help.nextcloud.com/user_avatar/help.nextcloud.com/nemskiller/64/875_2.png" class="avatar avatar-64 photo avatar-default" height="64" width="64">
						<b class="fn"><a href="https://help.nextcloud.com/t/nextcloud-introduces-collaborative-rich-text-editor/55605" rel="external" class="url">Nemskiller</a></b>
						<span class="says screen-reader-text">says:</span><!-- screen reader text -->
					</div>
					<div class="comment-metadata">
						<time datetime=""></time>
					</div>
				</footer>
				<div class="comment-content"><p>Good. It’s never too late.</p>
<p>This app could satisfy some users that can’t install Collabora/Onlyoffice and that just need a text edit in collaboration.</p>
</div>
			</article>
		</li>
				<li class="comment odd depth-1">
			<article class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt="" src="https://help.nextcloud.com/letter_avatar_proxy/v4/letter/j/49beb7/64.png" class="avatar avatar-64 photo avatar-default" height="64" width="64">
						<b class="fn"><a href="https://help.nextcloud.com/t/nextcloud-introduces-collaborative-rich-text-editor/55605" rel="external" class="url">jakob1</a></b>
						<span class="says screen-reader-text">says:</span><!-- screen reader text -->
					</div>
					<div class="comment-metadata">
						<time datetime=""></time>
					</div>
				</footer>
				<div class="comment-content"><p>Awesome app, works great! <img src="https://help.nextcloud.com/images/emoji/twitter/slight_smile.png?v=9" title=":slight_smile:" class="emoji" alt=":slight_smile:"></p>
<p>Now the texteditor, markdown and the notes app are obsolete.</p>
<p>I’m looking forward to see a good mobile integration.</p>
<p>Thanks a lot!</p>
</div>
			</article>
		</li>
				<li class="comment even depth-1">
			<article class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt="" src="https://help.nextcloud.com/user_avatar/help.nextcloud.com/necrevistonnezr/64/861_2.png" class="avatar avatar-64 photo avatar-default" height="64" width="64">
						<b class="fn"><a href="https://help.nextcloud.com/t/nextcloud-introduces-collaborative-rich-text-editor/55605" rel="external" class="url">necrevistonnezr</a></b>
						<span class="says screen-reader-text">says:</span><!-- screen reader text -->
					</div>
					<div class="comment-metadata">
						<time datetime=""></time>
					</div>
				</footer>
				<div class="comment-content"><p>Downloaded, activated - and now? There’s no app icon in the top bar. How do I create a collaborative document?</p></div>
			</article>
		</li>
				<li class="comment odd depth-1">
			<article class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt="" src="https://help.nextcloud.com/letter_avatar_proxy/v4/letter/j/49beb7/64.png" class="avatar avatar-64 photo avatar-default" height="64" width="64">
						<b class="fn"><a href="https://help.nextcloud.com/t/nextcloud-introduces-collaborative-rich-text-editor/55605" rel="external" class="url">jakob1</a></b>
						<span class="says screen-reader-text">says:</span><!-- screen reader text -->
					</div>
					<div class="comment-metadata">
						<time datetime=""></time>
					</div>
				</footer>
				<div class="comment-content"><p>Try this:<br>
Files App &gt; + Icon &gt; new text document</p></div>
			</article>
		</li>
				<li class="comment even depth-1">
			<article class="comment-body">
				<footer class="comment-meta">
					<div class="comment-author vcard">
						<img alt="" src="https://help.nextcloud.com/user_avatar/help.nextcloud.com/hevii_guy/64/1528_2.png" class="avatar avatar-64 photo avatar-default" height="64" width="64">
						<b class="fn"><a href="https://help.nextcloud.com/t/nextcloud-introduces-collaborative-rich-text-editor/55605" rel="external" class="url">Hevii_Guy</a></b>
						<span class="says screen-reader-text">says:</span><!-- screen reader text -->
					</div>
					<div class="comment-metadata">
						<time datetime=""></time>
					</div>
				</footer>
				<div class="comment-content"><p>Well, well; this is an exciting development. And, a welcome one! “Behind the scenes” markdown and non-proprietary .md format. Nice.</p>
<p>Finally, somebody has taken notice of what Users really want while at the same time keeping all camps satisfied. Too often, developers get caught up in their own code and give the middle finger to those expressing valid usability points-of-concern. With full Android integration, this looks like this could be an Evernotes/Joplin killer.</p>
</div>
			</article>
		</li>
		</ol>
			<div class="respond comment-respond">
				<h3 id="reply-title" class="comment-reply-title">
					Continue the discussion 								<a class="wpdc-discourse-topic-link" href="https://help.nextcloud.com/t/nextcloud-introduces-collaborative-rich-text-editor/55605">The Nextcloud forums</a>
							</h3>
				<p class="more-replies">1 more reply</p>
				<div class="comment-reply-title">
					<h4 class="discourse-participants">Participants</h4>
					<p>		<img alt="" src="https://help.nextcloud.com/user_avatar/help.nextcloud.com/system/64/843_2.png" class="avatar avatar-25 photo avatar-default" height="25" width="25">
				<img alt="" src="https://help.nextcloud.com/user_avatar/help.nextcloud.com/nemskiller/64/875_2.png" class="avatar avatar-25 photo avatar-default" height="25" width="25">
				<img alt="" src="https://help.nextcloud.com/user_avatar/help.nextcloud.com/necrevistonnezr/64/861_2.png" class="avatar avatar-25 photo avatar-default" height="25" width="25">
				<img alt="" src="https://help.nextcloud.com/user_avatar/help.nextcloud.com/hevii_guy/64/1528_2.png" class="avatar avatar-25 photo avatar-default" height="25" width="25">
				<img alt="" src="https://help.nextcloud.com/letter_avatar_proxy/v4/letter/j/49beb7/64.png" class="avatar avatar-25 photo avatar-default" height="25" width="25">
		</p>
				</div>
			</div>
		</div>
		    </div>
    </div>
</section>
  </article>
<style>
.hide {
    display: none !important;
}
</style>
<div class="alert alert--no-js" id="no-js">
  <div class="container" style="display: inherit">
		<svg width="32" height="32" viewBox="0 0 32 32" xmlns="http://www.w3.org/2000/svg">
  <g fill="none" fill-rule="evenodd">
    <path class="shape" stroke-width="2" stroke-linecap="round" stroke-linejoin="bevel" d="M16 1l15 30H1z"/>
    <path class="symbol" d="M16.898 22.53h-1.36l-.405-7.952h2.164l-.4 7.953zm-1.86 2.493c0-.385.103-.678.306-.878.203-.2.492-.3.867-.3.37 0 .656.103.853.31.198.21.297.5.297.868 0 .37-.1.663-.3.88-.202.215-.484.324-.85.324-.37 0-.657-.105-.862-.313-.206-.208-.31-.505-.31-.89z"/>
  </g>
</svg>
    <p style="display: inherit"><strong>You have javascript disabled.</strong> We tried to make sure the basics of our website work but some functionality will be missing.</p>
  </div>
</div>

<script>
    window.onload = (function(){
        // let's hope ONE of these removes the javascript warning.

        // first attempt, just adding the 'hide' class to make it display: none
        if(document.getElementById("no-js")) {
            var d = document.getElementById("no-js");
            d.className += " hide";
        }

        // second attempt, let's just remove the entire thing. If it doesn't work... hope the first attempt did work. Note, IE does not support the remove method
        if(document.querySelector("alert--no-js"))
            document.body.removeChild(document.querySelector("alert--no-js"));

    })();
</script>

<div class="cookiewarning" id="cookieConsent">
    <div class="container">
        <div class="text-center">
            This website is using cookies. By visiting you agree with our <a href="https://nextcloud.com/privacy" target="_blank">privacy policy.</a> <a class="cookieConsentOK">That's Fine</a>
        </div>
    </div>
</div>

<footer class="page-footer">
    <div class="container">
        <div class="col-sm-3">
            <h1 class="revealOnScroll">About Nextcloud</h1>
            <ul class="revealOnScroll">
                <li><a href="https://nextcloud.com/about">About us</a></li>
                <li><a href="https://nextcloud.com/contributors">Community</a></li>
                <li><a href="https://nextcloud.com/events">Events</a></li>
                <li><a href="https://nextcloud.com/jobs">Jobs</a></li>
                <li><a href="https://nextcloud.com/community/code-of-conduct/">Code of Conduct</a></li>
                <li><a href="https://nextcloud.com/privacy">Privacy</a></li>
                <li><a href="https://nextcloud.com/impressum">Legal notice</a></li>
            </ul>
        </div>
        <div class="col-sm-3">
            <h1  class="revealOnScroll">Resources</h1>
            <ul class="revealOnScroll">
                <li><a href="https://nextcloud.com/search">Search our website</a></li>
                <li><a href="https://nextcloud.com/install">Download</a></li>
                <li><a href="https://apps.nextcloud.com">App Store</a></li>
                <li><a href="https://docs.nextcloud.com/server/16/admin_manual/">Admin manual</a></li>
                <li><a href="https://docs.nextcloud.com/server/16/user_manual/">User manual</a></li>
                <li><a href="https://docs.nextcloud.com/server/16/developer_manual/">Developer manual</a></li>
                <li><a href="https://nextcloud.com/security">Security</a></li>
                <li><a href="https://github.com/nextcloud">Code on GitHub</a></li>
            </ul>
        </div>
        <div class="col-sm-3">
            <h1 class="revealOnScroll">Interact</h1>
            <ul  class="revealOnScroll">
                <li><a href="https://nextcloud.com/support">Support</a></li>
                <li><a href="https://webchat.freenode.net/?channels=nextcloud">IRC Channel</a></li>
                <li><a href="https://help.nextcloud.com/categories">Forums</a></li>
                <li><a href="https://demo.nextcloud.com">Demo</a></li>
                <li><a href="https://nextcloud.com/contact">Contact us</a></li>
                <li><a href="https://nextcloud.com/press">Press center</a></li>
                <li><a href="https://docs.nextcloud.com/server/16/developer_manual/bugtracker/">Bug Tracker</a></li>
            </ul>
        </div>
        <div class="col-sm-3">
            <h1 class="revealOnScroll">Follow us</h1>
            <ul  class="revealOnScroll">
                <li><a href="https://www.facebook.com/Nextcloud-1032807203462807/">Facebook</a></li>
                <li><a href="https://instagram.com/nextclouders">Instagram</a></li>
                <li><a href="https://www.linkedin.com/company/10827569/">LinkedIn</a></li>
                <li><a href="https://youtube.com/nextcloud">YouTube</a></li>
                <li><a href="https://twitter.com/nextclouders">Twitter</a></li>
                <li><a href="https://mastodon.xyz/@nextcloud">Mastodon</a></li>
                <li><a href="https://nextcloud.com/blogfeed">RSS Feed</a></li>
            </ul>
        </div>
    <div class="row">
		<div class="col-sm-12 text-center">
		<p  class="revealOnScroll">&copy; </font> 2019 Nextcloud GmbH</p>
		</div>
	</div>
  </div>
</footer>
<!-- Piwik -->
<script type="text/javascript">
  var _paq = _paq || [];
  /* tracker methods like "setCustomDimension" should be called before "trackPageView" */
  _paq.push(["setCookieDomain", "*.nextcloud.com"]);
  _paq.push(["setDomains", ["*.nextcloud.com"]]);
  _paq.push(['trackPageView']);
  _paq.push(['enableLinkTracking']);
  (function() {
    var u="//stats.nextcloud.com/";
    _paq.push(['setTrackerUrl', u+'piwik.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.type='text/javascript'; g.async=true; g.defer=true; g.src=u+'piwik.js'; s.parentNode.insertBefore(g,s);
  })();
</script>
<noscript><p><img src="//stats.nextcloud.com/piwik.php?idsite=1&rec=1" style="border:0;" alt="" /></p></noscript>
<!-- End Piwik Code -->
<!-- Mautic -->
<script>
    (function(w,d,t,u,n,a,m){w['MauticTrackingObject']=n;
        w[n]=w[n]||function(){(w[n].q=w[n].q||[]).push(arguments)},a=d.createElement(t),
        m=d.getElementsByTagName(t)[0];a.async=1;a.src=u;m.parentNode.insertBefore(a,m)
    })(window,document,'script','https://mautic.nextcloud.com/mtc.js','mt');

    mt('send', 'pageview');
</script>
<!-- End Mautic code -->
</body></html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/

Object Caching 0/91 objects using apc
Page Caching using apc (Empty response) 
Minified using apc
Database Caching using apc

Served from: nextcloud.com @ 2019-06-27 19:18:07 by W3 Total Cache
-->