Security Advisory

Back to advisories

Denial of Service by requesting to reset a password (NC-SA-2021-003)

3rd October 2020

Risk level: Low

CVSS v3 Base Score: 7.5 (AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H)

CWE: Denial of Service (CWE-400)

HackerOne report: 812754

Description

A wrong check in Nextcloud Server 19 and prior allowed to perform a denial of service attack when resetting the password for a user.

Affected Software

  • Nextcloud Server < 20.0.0 (CVE-2020-8295)

Action Taken

The error has been fixed.

Resolution

It is recommended that the Nextcloud Server is upgraded to 20.0.0.

Acknowledgements

The Nextcloud team thanks the following people for their research and responsible disclosure of the above advisory:


This advisory is licensed CC BY-SA 4.0.

You have javascript disabled. We tried to make sure the basics of our website work but some functionality will be missing.

This website is using cookies. By visiting you agree with our privacy policy. That's Fine