Security Advisory

Back to advisories

XSS in Files PDF viewer (NC-SA-2020-019)

18th March 2020

Risk level: Low

CVSS v3 Base Score: 3.5 (AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N)

CWE: Cross-site Scripting (XSS) - Generic (CWE-79)

HackerOne report: 819863

Description

An outdated 3rd party library in the Files PDF viewer for Nextcloud Server 18.0.2 caused a Cross-site scripting vulnerability when opening a malicious PDF.

Affected Software

  • Nextcloud Server < 18.0.3 (CVE-2020-8155)

Action Taken

The error has been fixed.

Resolution

It is recommended that the Nextcloud Server is upgraded to 18.0.3.

Acknowledgements

The Nextcloud team thanks the following people for their research and responsible disclosure of the above advisory:


This advisory is licensed CC BY-SA 4.0.

You have javascript disabled. We tried to make sure the basics of our website work but some functionality will be missing.

This website is using cookies. By visiting you agree with our privacy policy. That's Fine