Security Advisory

Back to advisories

Reflected XSS in redirect of the Updater (NC-SA-2020-007)

26th March 2019

Risk level: Low

CVSS v3 Base Score: 2 (AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N)

CWE: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') (CWE-79)

HackerOne report: 515484

Description

Missing escaping of HTML in the Updater of Nextcloud 15.0.5 allowed a reflected XSS when starting the updater from a malicious location.

Affected Software

  • Nextcloud Server < 15.0.6 (CVE-2019-15618)
  • Nextcloud Server < 14.0.9 (CVE-2019-15618)

Action Taken

The error has been fixed.

Resolution

It is recommended that the Nextcloud Server is upgraded to 15.0.6.

Acknowledgements

The Nextcloud team thanks the following people for their research and responsible disclosure of the above advisory:


This advisory is licensed CC BY-SA 4.0.

You have javascript disabled. We tried to make sure the basics of our website work but some functionality will be missing.

This website is using cookies. By visiting you agree with our privacy policy. That's Fine