Security Advisory

Back to advisories

2FA sessions not properly expired on password change (NC-SA-2020-001)

1st April 2019

Risk level: Low

CVSS v3 Base Score: 5.6 (AV:P/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N)

CWE: Session Fixation (CWE-384)

HackerOne report: 486693

Description

A bug in Nextcloud Server 15.0.2 causes pending 2FA logins to not be correctly expired when the password of the user is reset.

Affected Software

  • Nextcloud Server < 15.0.3 (CVE-2019-15612)
  • Nextcloud Server < 14.0.7 (CVE-2019-15612)
  • Nextcloud Server < 13.0.11 (CVE-2019-15612)

Action Taken

The error has been fixed.

Resolution

It is recommended that the Nextcloud Server is upgraded to 15.0.3.

Acknowledgements

The Nextcloud team thanks the following people for their research and responsible disclosure of the above advisory:

  • Jackson K V (jacksonkv67@gmail.com) - Vulnerability discovery and disclosure.

This advisory is licensed CC BY-SA 4.0.

You have javascript disabled. We tried to make sure the basics of our website work but some functionality will be missing.

This website is using cookies. By visiting you agree with our privacy policy. That's Fine