Security Advisory

Back to advisories

Improper validation of permissions (NC-SA-2018-010)

25th October 2018

Risk level: Low

CVSS v3 Base Score: 6.4 (AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N)

CWE: Improper Access Control - Generic (CWE-284)

HackerOne report: 388515

Description

Improper revalidation of permissions lead to not accepting access restrictions by acess tokens.

Affected Software

  • Nextcloud Server < 14.0.0 (CVE-2018-16466)
  • Nextcloud Server < 13.0.6 (CVE-2018-16466)
  • Nextcloud Server < 12.0.11 (CVE-2018-16466)

Action Taken

The error has been fixed.

Resolution

It is recommended that all instances are upgraded to Nextcloud 14.0.0, Nextcloud 13.0.6 or Nextcloud 12.0.11.

Acknowledgements

The Nextcloud team thanks the following people for their research and responsible disclosure of the above advisory:

  • Mohd Haji - Vulnerability discovery and disclosure.

This advisory is licensed CC BY-SA 4.0.

You have javascript disabled. We tried to make sure the basics of our website work but some functionality will be missing.

This website is using cookies. By visiting you agree with our privacy policy. That's Fine