Security Advisory

Back to advisories

Message Authentication Codes calculated by the Default Encryption Module allow an attacker to silently overwrite blocks in a file (NC-SA-2020-038)

26th August 2020

Risk level: Low

CVSS v3 Base Score: 1.8 (AV:L/AC:H/PR:H/UI:R/S:U/C:N/I:L/A:N)

CWE: Violation of Secure Design Principles (CWE-657)

HackerOne report: 661051

Description

A wrong generation of the passphrase for the encrypted block in Nextcloud Server 19.0.1 allowed an attacker to overwrite blocks in a file.

Affected Software

  • Nextcloud Server < 19.0.2 (CVE-2020-8133)
  • Nextcloud Server < 18.0.8 (CVE-2020-8133)
  • Nextcloud Server < 17.0.10 (CVE-2020-8133)

Action Taken

The error has been fixed.

Resolution

It is recommended that the Nextcloud Server is upgraded to 19.0.2.

Acknowledgements

The Nextcloud team thanks the following people for their research and responsible disclosure of the above advisory:


This advisory is licensed CC BY-SA 4.0.

You have javascript disabled. We tried to make sure the basics of our website work but some functionality will be missing.

This website is using cookies. By visiting you agree with our privacy policy. That's Fine